Let us define the custom tribonacci sequence as follows. To = A T₁ = B T₂ = C Ti = Ti-3 + Ti-2 + Ti-1 for i ≥ 3 Given A, B, C, and i, output T; mod 10⁹ +7 Input Format Input consists of one line containing four space-separated integers A, B, C, and i as des problem statement. Constraints 0 ≤ A, B, C, i ≤ 260 Output Format Output one line containing T; mod 10⁹ +7

Systems Architecture
7th Edition
ISBN:9781305080195
Author:Stephen D. Burd
Publisher:Stephen D. Burd
Chapter10: Application Development
Section: Chapter Questions
Problem 6VE
icon
Related questions
Question
100%

CTS Problem Set

Kindly answer using Divide and Conquer algorithms

Can be answered in Pypy 3 or Java 8

Sample Input 0
0 0 1 3
Sample Output 0
1
Sample Input 1
4224
Sample Output 1
12
Sample Input 2
2 116
Sample Output 2
21
1 def solve(a,b,c,i):
2
3556N
4
MOD
1000000007
# compute and return answer here
a, b, c, i = list (map
6 print (solve(a,b,c, i))
(int,input().rstrip().split(" ")))
Transcribed Image Text:Sample Input 0 0 0 1 3 Sample Output 0 1 Sample Input 1 4224 Sample Output 1 12 Sample Input 2 2 116 Sample Output 2 21 1 def solve(a,b,c,i): 2 3556N 4 MOD 1000000007 # compute and return answer here a, b, c, i = list (map 6 print (solve(a,b,c, i)) (int,input().rstrip().split(" ")))
Custom Tribonacci Sequence
Problem
= A
Submissions
Let us define the custom tribonacci sequence as follows.
To
T₁ = B
T₂ = C
Ti = Ti-3 + Ti-2 + Ti-1 for i ≥ 3
Given A, B, C, and i, output T; mod 10⁹ +7
Input Format
Input consists of one line containing four space-separated integers A, B, C, and i as described in the
problem statement.
Constraints
Discussions
0 ≤ A, B, C, i < 260
Output Format
Output one line containing T; mod 10⁹ +7
Transcribed Image Text:Custom Tribonacci Sequence Problem = A Submissions Let us define the custom tribonacci sequence as follows. To T₁ = B T₂ = C Ti = Ti-3 + Ti-2 + Ti-1 for i ≥ 3 Given A, B, C, and i, output T; mod 10⁹ +7 Input Format Input consists of one line containing four space-separated integers A, B, C, and i as described in the problem statement. Constraints Discussions 0 ≤ A, B, C, i < 260 Output Format Output one line containing T; mod 10⁹ +7
Expert Solution
trending now

Trending now

This is a popular solution!

steps

Step by step

Solved in 3 steps with 3 images

Blurred answer
Knowledge Booster
Use of XOR function
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
  • SEE MORE QUESTIONS
Recommended textbooks for you
Systems Architecture
Systems Architecture
Computer Science
ISBN:
9781305080195
Author:
Stephen D. Burd
Publisher:
Cengage Learning