The problem asks you to write a code to read the firstName, lastName, age, and weight of a person from the console all in one single line and print them as follow:

Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
icon
Related questions
Question

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Answer in Java below.

The problem asks you to write a code to read the firstName, lastName, age, and weight of a person from the console all in one single line and print them as follow:

Sample input:

John Smith 61 189.12131

 

Sample output:

First name: John

Last name: Smith

Your age is 61 and your weight is 189.12

 

- solution.java:

import java.util.*;

import java.lang.*;

import java.io.*;

 

class ProblemSolution

{

public void solution(){

Scanner input = new Scanner(System.in);

String inputString = input.nextLine().trim();

int i = inputString.indexOf(' ');

int j = inputString.indexOf(' ', i+1);

int k = inputString.indexOf(' ', j+1);

String firstName = inputString.substring(0,i);

String lastName = inputString.substring(i+1, j);

int age = Integer.parseInt(inputString.substring(j+1, k));

double weight = Double.parseDouble(inputString.substring(k+1));

 

System.out.println("FirstName: " + firstName);

System.out.println("LastName: " + lastName);

System.out.printf("Your age is %d and your weight is %.2f", age, weight);

}

}

 

class DriverMain

{

public static void main(String args[])

{

ProblemSolution problemSolution = new ProblemSolution();

problemSolution.solution();

}

}

Expert Solution
trending now

Trending now

This is a popular solution!

steps

Step by step

Solved in 2 steps with 2 images

Blurred answer
Knowledge Booster
Array
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
  • SEE MORE QUESTIONS
Recommended textbooks for you
Database System Concepts
Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education
Starting Out with Python (4th Edition)
Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON
Digital Fundamentals (11th Edition)
Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON
C How to Program (8th Edition)
C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON
Database Systems: Design, Implementation, & Manag…
Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning
Programmable Logic Controllers
Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education