
Binary Search of Strings
1. Write a version of the selection sort
to search a list of strings.
2. Write a version of the binary search algorithm presented in the unit, which is
used to search a list of strings. (Use the selection sort that you designed above
to sort the list of strings.)
3. Create a test
then prompts the user to enter a search string. Your program should then search
the list using your binary search algorithm to determine if the string is in the list.
Allow the user to continue to search for strings until they choose to exit the
program

Trending nowThis is a popular solution!
Step by stepSolved in 2 steps with 1 images

- In C ++ You will need to sort whitespace-separated integers using three different sort algorithms (described here: http://theoryapp.com/selection-insertion-and-bubble-sort/ and https://en.wikipedia.org/wiki/Insertion_sort). For each of the three sorting algorithms (selection, insertion, and bubble), your program should output the initial list of numbers as well as after each swap. Note: You should use the Wikipedia entry for insertion sort. Do not perform swaps if they don't change the vector. Example Input: 1 1 6 3 8 4 2 3 9 2 4 Output: 1 Selection Sort 2 1 6 3 8 4 2 3 9 2 4 3 1 2 3 8 4 6 3 9 2 4 4 1 2 2 8 4 6 3 9 3 4 5 1 2 2 3 4 6 8 9 3 4 6 1 2 2 3 3 6 8 9 4 4 7 1 2 2 3 3 4 8 9 6 4 8 1 2 2 3 3 4 4 9 6 8 9 1 2 2 3 3 4 4 6 9 8 10 1 2 2 3 3 4 4 6 8 9 11 Insertion Sort 12 1 6 3 8 4 2 3 9 2 4 13 1 3 6 8 4 2 3 9 2 4 14 1 3 6 4 8 2 3 9 2 4 15 1 3 4 6 8 2 3 9 2 4 16 1 3 4 6 2 8 3 9 2 4 17 1 3 4 2 6 8 3 9 2 4 18 1 3 2 4 6 8 3 9 2 4 19 1 2 3 4 6 8 3…arrow_forward2. count_fred_and_ted Given a list of strings called names , count up how many of those names are either "fred" or "ted", and return the count. Sample calls should look like: >>> count_fred_and_ted(["sarah", "bimmy", "fred", "eliza", "ted", "ted"]) 3 >> count_fred_and_ted(["sarah", "bimmy", "bimmy", "bimmy", "bimmy"]) >>> count_fred_and_ted(["fred", "ted", "fred", "ted"]) 4 >>> count_fred_and_ted([])arrow_forwardpython LAB: Subtracting list elements from max When analyzing data sets, such as data for human heights or for human weights, a common step is to adjust the data. This can be done by normalizing to values between 0 and 1, or throwing away outliers. Write a program that adjusts a list of values by subtracting each value from the maximum value in the list. The input begins with an integer indicating the number of integers that follow.arrow_forward
- The top three most popular male names of 2017 are Oliver, Declan, and Henry, according to babynames.com. Write a program that modifies the male_names set by removing a name and adding a different name. Sample output with inputs: 'Oliver' 'Atlas' { 'Atlas', 'Declan', 'Henry' } NOTE: Because sets are unordered, the order in which the names in male_names appear may differ from above. Code writing challenge activity demo 461710.3116374.qx3zqy7 1 male_names 2 name_to_remove = input() 3 name_to_add=input() 4 = 11 { 'Oliver', 'Declan', 'Henry' } 5 6 7 print (male_names) Your solution goes here '''arrow_forwardInteger num_reading is read from input, representing the number of integers to be read next. Read the remaining integers from input and insert each integer at the front of reading_list at position 0.arrow_forwardQuestion in image Please explain the algorithm with the answer. Python programmingarrow_forward
- python please make it simplearrow_forwardFor each of the following write a list comprehension: a. Create a list of the first 10 multiples of 13 (from 13 to 130) b. Create a list of the squares of the first 100 integers, but only with those that are odd.arrow_forwardUsing c++ Contact list: Binary Search A contact list is a place where you can store a specific contact with other associated information such as a phone number, email address, birthday, etc. Write a program that first takes as input an integer N that represents the number of word pairs in the list to follow. Word pairs consist of a name and a phone number (both strings). That list is followed by a name, and your program should output the phone number associated with that name. Define and call the following function. The return value of FindContact is the index of the contact with the provided contact name. If the name is not found, the function should return -1 This function should use binary search. Modify the algorithm to output the count of how many comparisons using == with the contactName were performed during the search, before it returns the index (or -1). int FindContact(ContactInfo contacts[], int size, string contactName) Ex: If the input is: 3 Frank 867-5309 Joe…arrow_forward
- Write a version of the binary search algorithm that can be used to search a list of strings. (Use the selection sort that you designed to sort the list.)arrow_forwardPYTHON Complete the function below, which takes two arguments: data: a list of tweets search_words: a list of search phrases The function should, for each tweet in data, check whether that tweet uses any of the words in the list search_words. If it does, we keep the tweet. If it does not, we ignore the tweet. data = ['ZOOM earnings for Q1 are up 5%', 'Subscriptions at ZOOM have risen to all-time highs, boosting sales', "Got a new Mazda, ZOOM ZOOM Y'ALL!", 'I hate getting up at 8am FOR A STUPID ZOOM MEETING', 'ZOOM execs hint at a decline in earnings following a capital expansion program'] Hint: Consider the example_function below. It takes a list of numbers in numbers and keeps only those that appear in search_numbers. def example_function(numbers, search_numbers): keep = [] for number in numbers: if number in search_numbers(): keep.append(number) return keep def search_words(data, search_words):arrow_forwardJava Task Write a for loop that prints the characters stored in a String object backward. The String is entered by the user. ***Use ch = phrase.charAt(i); to get the character that is in index i of the String phrase.**** For example The user enters “Good morning!” The printout should be “!gninrom dooG”.arrow_forward
- Database System ConceptsComputer ScienceISBN:9780078022159Author:Abraham Silberschatz Professor, Henry F. Korth, S. SudarshanPublisher:McGraw-Hill EducationStarting Out with Python (4th Edition)Computer ScienceISBN:9780134444321Author:Tony GaddisPublisher:PEARSONDigital Fundamentals (11th Edition)Computer ScienceISBN:9780132737968Author:Thomas L. FloydPublisher:PEARSON
- C How to Program (8th Edition)Computer ScienceISBN:9780133976892Author:Paul J. Deitel, Harvey DeitelPublisher:PEARSONDatabase Systems: Design, Implementation, & Manag...Computer ScienceISBN:9781337627900Author:Carlos Coronel, Steven MorrisPublisher:Cengage LearningProgrammable Logic ControllersComputer ScienceISBN:9780073373843Author:Frank D. PetruzellaPublisher:McGraw-Hill Education





