
String Practice Problem
Complete the following
a) Read in and store the data from the file called"January.txt". This file includes the customer's account number,beginning balance, withdrawals, and deposits. (In that order) Note:Make sure you look at the file before you begin the project!
b) Prompt the user for his/her name and age.
c) Convert the customer's name to a username that consists ofthe first letter of the first name, the first 5 digits of lastname, and the customer's age.(All letters should be lowercase)Example: Michael Jordan, age 37 should convert to: mjorda37
d) Convert the account number to the following format:XXX-XX-XXX
e) Calculate the total of the deposits, the total of thewithdrawals, and the ending balance in the account.
f) Write a report similar to the following to both thescreen and a file called "January statement.txt":
Broward College National Bank
January Bank Statement
Name UserName Account Number
--------------------------------------------------------------------
Michael Jordan mjorda37 217-28-392
Beginning Balance: $1200.56
Total Withdrawals: $339.18
Total Deposits: $530.29
Ending Balance: $1391.67
Save the file as lastname_statement.py and upload the .py file here.

Trending nowThis is a popular solution!
Step by stepSolved in 3 steps with 3 images

- JAVA PROGRAMMINGIf Statements - Program #1Ms. Monroe is an Income Tax Practitioner who operated a service that prepares income taxforms. Her fees are based on the type of form filed and yearly income.Program Specifications:a. Create a folder named If Program 01. Save the Java file as TaxPrep.b. Input consists of the customer's name, the form type (1 - short form; 2 - long form), andthe yearly income. Sample input is illustrated on page 2. You will enter the input from thekeyboard. Input prompts should be very specific. When inputting the form type makesure that you display 1 – Short Form or 2 – Long Form. The user needs to know what toenter. This program will process one record and only one record at a time.c. The basic fee is $100 for a short form (form type of 1) or $200 for a long form (form typeof 2). The income fee is based on the yearly income. If the yearly income is less the$50,000, the income fee is the same as the basic fee. If the yearly income is $50,000 ormore, the income…arrow_forwardInstructions C++ 8-17 A company hired 10 temporary workers who are paid hourly and you are given a data file that contains the last name of the employees, the number of hours each employee worked in a week, and the hourly pay rate of each employee. You are asked to write a program that computes each employee’s weekly pay and the average salary of all employees. The program then outputs the weekly pay of each employee, the average weekly pay, and the names of all the employees whose pay is greater than or equal to the average pay. If the number of hours worked in a week is more than 40, then the pay rate for the hours over 40 is 1.5 times the regular hourly rate. Use two parallel arrays: a one-dimensional array to store the names of all the employees (Name) a two-dimensional array of 10 rows and 3 columns to store the number of hours an employee worked in a week (Hrs Worked), the hourly pay rate (Pay Rate), and the weekly pay (Salary). Your program must contain at least the following…arrow_forwardHeader (.h) files contain all of the declarations of a program. Non-header (.cpp)files contain all the definitions… TRUE OR FALSEarrow_forward
- python use the "get_first_name" function in the "names" module and create a list of 8 first-names.arrow_forwardPYTHON data = ['ZOOM earnings for Q1 are up 5%', 'Subscriptions at ZOOM have risen to all-time highs, boosting sales', "Got a new Mazda, ZOOM ZOOM Y'ALL!", 'I hate getting up at 8am FOR A STUPID ZOOM MEETING', 'ZOOM execs hint at a decline in earnings following a capital expansion program'] def scan_tweets(data):earnings_words = ['earnings', 'sales']positive_words = ['up', 'rise']negative_words = ['decline'] relevant_tweets = search_words(data=data, search_words=earnings_words) return positive_tweets, negative_tweets print(scan_tweets(data))arrow_forwardQ1: Write a C# program that reads an "info.txt" file containing students' information in the following form "Name: Average". Then, put the name of students into "Name.txt file and the averages of them into "Average.txt" file. 6arrow_forward
- PYTHON QUESTION #6 Two programs are required. In each program: Start with a comment that includes your name and course number. Include pseudocode that describes all steps required to solve the problem. Employ variable names that describe the values they store and adhere to Python naming conventions. Include additional comments as needed to annotate your code. Use correct spelling and grammar. 5a: Write a program named filemaker.py that will be used to store the first name and age of some friends in a text file named friends.txt. The program must use a while loop that prompts the user to enter the first name and age of each friend. Each of these entries should be written to its own line in the text file (2 lines of data per friend). The while loop should repeat until the user presses Enter (Return on a Mac) for the name. Then, the file should be closed and a message should be displayed. See Sample Output.SAMPLE OUTPUT Enter first name of friend or Enter to quit DennyEnter age…arrow_forward1)Write a program to create a structure employee having name, id,salary. Create a file “employee.txt” and open in append mode. Write the detail of 5 employee into a file and read the data from the file and display name of employee having highest salary on screen. Use C++arrow_forward# Debug the following program and submit the CORRECT version ####### Lists names = ["chris","dan", "edgar", "bonnie", "al", "fran"] usernames = ["202999", "100345", "299999", "309890", "298765", "345678"] passwords = ["password", "password123", "abcdef", "asdfjkl;", "ilovemom", "abc123"] menuChoice = 0 # user's menu choice ###### functions def printList(list):# print listprintprint(list)print def displayMenu():# displays user-friendly, creative menu printprintprint("******* MENU *******")print("1. (D)isplay list 1 in original order")print("2. D(I)splay list 2 in original order")print("3. (F)ind an item in the list 1")print("4. (L)ogin")print("99. (E)xit")printprint def isFound(list, value):# finds a value in list returns True if found, False otherwiseif (value in list):return Trueelse: return False ###### main program while (menuChoice != "99"):displayMenu()menuChoice = input("Enter a menu choice: ")# handling menu choices if (menuChoice == "10" or menuChoice.upper().strip() ==…arrow_forward
- Computer Networking: A Top-Down Approach (7th Edi...Computer EngineeringISBN:9780133594140Author:James Kurose, Keith RossPublisher:PEARSONComputer Organization and Design MIPS Edition, Fi...Computer EngineeringISBN:9780124077263Author:David A. Patterson, John L. HennessyPublisher:Elsevier ScienceNetwork+ Guide to Networks (MindTap Course List)Computer EngineeringISBN:9781337569330Author:Jill West, Tamara Dean, Jean AndrewsPublisher:Cengage Learning
- Concepts of Database ManagementComputer EngineeringISBN:9781337093422Author:Joy L. Starks, Philip J. Pratt, Mary Z. LastPublisher:Cengage LearningPrelude to ProgrammingComputer EngineeringISBN:9780133750423Author:VENIT, StewartPublisher:Pearson EducationSc Business Data Communications and Networking, T...Computer EngineeringISBN:9781119368830Author:FITZGERALDPublisher:WILEY





