
Computer Networking: A Top-Down Approach (7th Edition)
7th Edition
ISBN: 9780133594140
Author: James Kurose, Keith Ross
Publisher: PEARSON
expand_more
expand_more
format_list_bulleted
Question
Using python, write a main() function that will ask the user for three integers (0, 1 or 2) and draw the corresponding sign..
For example, if the user enters 2, 0, and 2, the output will be:
*****
*
*****
*
*****
*****
* *
* *
* *
*****
*****
*
*****
*
*****
Expert Solution

This question has been solved!
Explore an expertly crafted, step-by-step solution for a thorough understanding of key concepts.
This is a popular solution
Trending nowThis is a popular solution!
Step by stepSolved in 2 steps with 1 images

Knowledge Booster
Similar questions
- A pedometer treats walking 1 step as walking 2.5 feet. Define a function named feet_to_steps that takes a float as a parameter, representing the number of feet walked, and returns an integer that represents the number of steps walked. Then, write a main program that reads the number of feet walked as an input, calls function feet_to_steps with the input as an argument, and outputs the number of steps as an integer. Use floating-point arithmetic to perform the conversion. Ex: If the input is: 150.5 the output is: 60 The program must define and call the following function: def feet_to_steps (user_feet) 461710.3116374.qx3zqy7 LAB ACTIVITY 7.10.1: LAB: Step counter 1 # Define your function here 3 if __name_ 4 '__main__': #Type your code here. main.py 0/10 Load default template...arrow_forwardPlease answer it in Python Write a function input_names that takes as an argument a number player (supposedly valid) corresponding to the number of players who will play the game and which successively asks for the name of each player. The function verifies that the names of the players are all different and returns the list of the names of the players. The messages will ‑have to be clear. For example: input_names(3) #return => Enter player name 1: rara Enter player name 2: rara Enter player name 2: riri Enter player name 3: roro [“rara”,”riri”,”roro”] Input_names(2) #return => Enter player name 1: roro Enter player name 2 : raraarrow_forwardWrite a python code:arrow_forward
- please use python function should do the following: when the function input is ([[11, 11, 11, 11, 11], [1, 5, 5, 5, 7], [255, 255, 255, 0, 255]]) the output should be [['11x5'], ['1x1', '5x3', '7x1'], ['255x3', '0x1', 255x1']] functions/methods (please DO NOT use functions that are not specified here):sum() min() max() list append() list insert() list remove() list pop() list count() list index() list sort() str capitalize() str isupper() str strip() str split() str join() id() len() str lower() str upper() str replace() str count() str find()arrow_forwardComputer Science We are making n stone piles! The first pile has n stones. If n is even, then all succeeding piles will have an even number of stones. If n is odd, all succeeding piles will have an odd number of stones. Each pile must be more stones than the previous pile but as few as possible. Write a Python function to find and display the number of stones in each pile. The function should accept 1 argument that represents the initial number of stones in pile 1 and the number of piles to be generated.arrow_forwardUsing Pythonarrow_forward
- Write a function number_of_pennies() that returns the total number of pennies given a number of dollars and (optionally) a number of pennies. Ex: If you have $5.06 then the input is 5 6, and if you have $4.00 then the input is 4. Sample output with inputs: 5 64 506 400 Learn how our autograder works 461710.3116374.qx3zqy7 1 2 Your solution goes here '' 3 4 print (number_of_pennies (int(input()), int(input()))) 5 print(number_of_pennies (int(input()))) # Both dollars and pennies # Dollars onlyarrow_forwardCreating a function table, python code from the following pictures:arrow_forwardFirst write a function f to generate and return a random number between 0 to 100 In the main function, you keep calling function f until the returned value is less than 10 Then you should print out how many times the function f has been called. Note that every time f will only return a single random number, and the declaration of f is as follows: int f() For instance, if f returns 23, 89, 10, 1, then your program should print 4 on the screen. C++ language Hint 1. You can implement the function using different methods, like the static variable Hint 2. You can use the modular operator to shrink the generated random value, i.e., random() % 101 will guarantee the result is between 0 and 100.arrow_forward
- My Birthday Function Write a well-documented Python program, hmwk4Q4.py, that simulates a single trial of a person walking into a room on N people and determining if their birthday matches any of the other N people in the room. Design a function myBirthday (N) that returns True if a match is found, or False if no match is found. Import the python random number module into your program. On a single trial, with a user input 200 people, you may not find someone with your birthday. If you manually rerun the simulation ten times, your code, however, should see that approximately four (4.22 exactly) times there is a match to your birthday.arrow_forwardWrite a program that prompts the user to input a sequence of characters and outputs the number of vowels. (Use the function isVowel written in part 1). Write the function prototype for the isVowel function Write the function call for the isVowel function Attach the input and output of a successful execution of your program below (Hint: Use the snipping tool to take screenshots):arrow_forwardUse Python Write a function, print_integers_less_than(n), which takes an integer parameter n and prints each integer k which is at least 0 and is less than n, in ascending order. Hint: use a simple for loop. For example: Test Result print_integers_less_than(2) 0 1 print_integers_less_than(5) 0 1 2 3 4 print_integers_less_than(-3)arrow_forward
arrow_back_ios
SEE MORE QUESTIONS
arrow_forward_ios
Recommended textbooks for you
- Computer Networking: A Top-Down Approach (7th Edi...Computer EngineeringISBN:9780133594140Author:James Kurose, Keith RossPublisher:PEARSONComputer Organization and Design MIPS Edition, Fi...Computer EngineeringISBN:9780124077263Author:David A. Patterson, John L. HennessyPublisher:Elsevier ScienceNetwork+ Guide to Networks (MindTap Course List)Computer EngineeringISBN:9781337569330Author:Jill West, Tamara Dean, Jean AndrewsPublisher:Cengage Learning
- Concepts of Database ManagementComputer EngineeringISBN:9781337093422Author:Joy L. Starks, Philip J. Pratt, Mary Z. LastPublisher:Cengage LearningPrelude to ProgrammingComputer EngineeringISBN:9780133750423Author:VENIT, StewartPublisher:Pearson EducationSc Business Data Communications and Networking, T...Computer EngineeringISBN:9781119368830Author:FITZGERALDPublisher:WILEY

Computer Networking: A Top-Down Approach (7th Edi...
Computer Engineering
ISBN:9780133594140
Author:James Kurose, Keith Ross
Publisher:PEARSON

Computer Organization and Design MIPS Edition, Fi...
Computer Engineering
ISBN:9780124077263
Author:David A. Patterson, John L. Hennessy
Publisher:Elsevier Science

Network+ Guide to Networks (MindTap Course List)
Computer Engineering
ISBN:9781337569330
Author:Jill West, Tamara Dean, Jean Andrews
Publisher:Cengage Learning

Concepts of Database Management
Computer Engineering
ISBN:9781337093422
Author:Joy L. Starks, Philip J. Pratt, Mary Z. Last
Publisher:Cengage Learning

Prelude to Programming
Computer Engineering
ISBN:9780133750423
Author:VENIT, Stewart
Publisher:Pearson Education

Sc Business Data Communications and Networking, T...
Computer Engineering
ISBN:9781119368830
Author:FITZGERALD
Publisher:WILEY