
Database System Concepts
7th Edition
ISBN: 9780078022159
Author: Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher: McGraw-Hill Education
expand_more
expand_more
format_list_bulleted
Question
thumb_up100%
Implement the following:
1) Use a loop to continuously request an integer input from the console.
2) As long as the value is in the range from -10 to 10 inclusive, request new values.
3) Once the value is not in the range above, end the loop.
4) Prompt a message and print the sum of all valid values.
Input text can be any content. Just make sure to match the output format below.
Example Output
Enter a number (-10, 10): 0
Enter a number (-10, 10): 1
Enter a number (-10, 10): -1
Enter a number (-10, 10): 11
Number out of range entered. Loop terminates.
0
PYTHON PROGRAMMING HW
Expert Solution

This question has been solved!
Explore an expertly crafted, step-by-step solution for a thorough understanding of key concepts.
This is a popular solution
Trending nowThis is a popular solution!
Step by stepSolved in 2 steps

Knowledge Booster
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.Similar questions
- 4- Write a script that will generate random integers in the range from 0 to 50, and print them, until one is finally generated that is greater than 40. The script should print how many attempts it took.arrow_forward"Simon Says" is a memory game where "Simon" outputs a sequence of 10 characters (R, G, B, Y) and the user must repeat the sequence. Create a for loop that compares each character of the two strings. For each matching character, add one point to user_score. Upon a mismatch, end the loop. Sample output with inputs: 'RRGBRYYBGY' 'RRGBBRYBGY' User score: 4 Learn how our autograder works 487180.3542414.qx3zqy7 1 user_score= 0 2 simon_pattern = input() 3 user_pattern input() 4 5 for i in range(len(simon_pattern)): 6 if simon_pattern[i] user_score=4 7 8 9 10 == user_pattern[i]:arrow_forwardWrite a do-while loop that continues to prompt a user to enter a number less than 100, until the entered number is actually less than 100. End each prompt with newline Ex: For the user input 123, 395, 25, the expected output is: Enter a number (<100): Enter a number (<100): Enter a number (<100): Your number < 100 is: 25arrow_forward
- write a loop that displays all ossible combinations of two letter there the letters are 'a', or 'b', 'c', 'd', or 'e'. the combinations should be displayed in ascending alphabetical order: aa ab ac etc using python and a nested looparrow_forwardTASK: Your task is to write code which handles a sequence of input characters from the UART interface, and responds with the output specified below. On receipt of the character sequence: - "foo" your program should print '0'. - "bar" your program should print '1'. - "foobar" your program should not print either '0' or '1' as specified above, but should instead print a linefeed '\n' character. NOTE: It is strongly recommended that you design a state machine to complete this task. Your solution should use a baud rate of 9600, and 8N1 frame format. Your solution MUST NOT use qutyio.o or qutyserial.o. EXAMPLES: INPUT: ...foo.bar.foo.barfoobarfood OUTPUT: 0101\n0 (START)0101 0(END) INPUT: barsfoosbarforbarfoobarrforfoobarfoobarfood OUTPUT: 1011\n\n\n0 (START)1011 0(END) */arrow_forwardGiven the code: int x, y: cout > x >> y: Write a loop to print all numbers that are factors of x and not factors of y. Example Output 1 Enter two integers: 12 30 4 12 Example Output 2 Enter two integers: 15 24 5 15arrow_forward
- Write a program that • Requests a temperature from the user. • Also asks if the temperature is in Fahrenheit (F) or Celsius (C). • Converts the entered temperature to the other scale. • Prints out the result as illustrated below. The conversion formulas are c=등(F-32) F =C+ 32 andarrow_forwardAssignment: Check the Sample run first, then carefully read the instructions and write aprogram that prompts the user for first name, last name, then secret number. The output willgenerate a default email address and a default password. 1. The main method will do the following:• Asks the user for first name, last name, and secret number using Scanner. (first lettercan be in upper case)• Call defaultInfo(String, String) method to PRINT default Kean email address.• Call defaultInfo(String, int) method to PRINT default Kean password.• Note: You are using overloaded methods (i.e., same method name with differentparameter lists) 2. Write an overloaded method, defaultInfo, which does the following:• public static void defaultInfo(String firstName, String lastName) [Note:you can use your own variable name]‒ print default email address all in low caps: concatenate first letter offirstName, full lastName, and @gmail.com. [Hint: string.charAt(index),string.toLowerCase()]• public static void…arrow_forwardGiven the code:int x;cout << "Enter an integer: ";cin >> x; Write a loop to print all numbers from 1 to x inclusive that are not factors of x.Example Output 1Enter an integer: 125 7 8 9 10 11Example Output 2Enter an integer: 92 4 5 6 7 8arrow_forward
- Write a for loop that calculates the total of the following series of numbers: 1/30 + 2/29 + 3/28 + ... = 30/1 Submit the source code.arrow_forwardCHALLENGE ACTIVITY 5.2.3: Basic while loop expression. Write a while loop that repeats while user_num ≥ 1. In each loop iteration, divide user_num by 2, then print user_num.Sample output with input: 2010.0 5.0 2.5 1.25 0.625 Note: If the submitted code has an infinite loop, the system will stop running the code after a few seconds and report "Program end never reached." The system doesn't print the test case that caused the reported message.arrow_forwardIn PYTHON Using one of the loop construct draw:- Ten dashed Horizontal lines- Each line of length 150 units (or pixels)- All lines aligned at the same left vertical margin- Lines 10 units apart each other Note- Set the length of solid segment to 10 units- Set the length of the non-visible segment to 5 units Assumption- Use of Turtle library (i will check the answer, it has to be correct)arrow_forward
arrow_back_ios
SEE MORE QUESTIONS
arrow_forward_ios
Recommended textbooks for you
- Database System ConceptsComputer ScienceISBN:9780078022159Author:Abraham Silberschatz Professor, Henry F. Korth, S. SudarshanPublisher:McGraw-Hill EducationStarting Out with Python (4th Edition)Computer ScienceISBN:9780134444321Author:Tony GaddisPublisher:PEARSONDigital Fundamentals (11th Edition)Computer ScienceISBN:9780132737968Author:Thomas L. FloydPublisher:PEARSON
- C How to Program (8th Edition)Computer ScienceISBN:9780133976892Author:Paul J. Deitel, Harvey DeitelPublisher:PEARSONDatabase Systems: Design, Implementation, & Manag...Computer ScienceISBN:9781337627900Author:Carlos Coronel, Steven MorrisPublisher:Cengage LearningProgrammable Logic ControllersComputer ScienceISBN:9780073373843Author:Frank D. PetruzellaPublisher:McGraw-Hill Education

Database System Concepts
Computer Science
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:McGraw-Hill Education

Starting Out with Python (4th Edition)
Computer Science
ISBN:9780134444321
Author:Tony Gaddis
Publisher:PEARSON

Digital Fundamentals (11th Edition)
Computer Science
ISBN:9780132737968
Author:Thomas L. Floyd
Publisher:PEARSON

C How to Program (8th Edition)
Computer Science
ISBN:9780133976892
Author:Paul J. Deitel, Harvey Deitel
Publisher:PEARSON

Database Systems: Design, Implementation, & Manag...
Computer Science
ISBN:9781337627900
Author:Carlos Coronel, Steven Morris
Publisher:Cengage Learning

Programmable Logic Controllers
Computer Science
ISBN:9780073373843
Author:Frank D. Petruzella
Publisher:McGraw-Hill Education