Starting Out with C++ from Control Structures to Objects (8th Edition)
Starting Out with C++ from Control Structures to Objects (8th Edition)
8th Edition
ISBN: 9780133778793
Author: GADDIS
Publisher: PEARSON
bartleby

Videos

Textbook Question
Book Icon
Chapter 2, Problem 8RQE

What will the following programs print on the screen?

A) #include <iostream>

using namespace std;

int main()

{

int freeze = 32, boil = 212;

freeze = 0;

boil = 100;

cout ≪ freeze ≪ endl ≪ boil ≪ endl ;

return 0;

}

B) #include <iostream>

using namespace std;

int main()

{

int x = 0, y = 2;

x = y * 4;

cout ≪ x ≪ endl ≪ y ≪ endl ;

return 0;

}

C) #include <iostream>

using namespace std;

int main()

{

cout ≪ “I am the incredible”;

cout ≪ “computing\nmachine”;

cout ≪ “\nand I will\namaze\n”;

cout ≪ “you.”;

return 0;

}

D) #include <iostream>

using namespace std;

int main()

{

cout ≪ “Be careful\n”;

cout ≪ “This might/n be a trick ”;

cout ≪ “question\n”;

return 0;

}

E) #include <iostream>

using namespace std;

int main()

{

int a, x = 23;

a = x % 2;

cout ≪ x ≪ endl ≪ a ≪ endl ;

return 0;

}

Blurred answer
Students have asked these similar questions
struct date{ int day; int month; int year; };   Write a function named void increaseDay(struct date *d) that increases the value of a variable of struct date type with integer year, month, and day members by one day. Write a function named void decreaseDay(struct date *d) that decreases the value of a variable of struct date type with integer year, month, and day members by one day. Write a C program that reads from the user a date in d/m/y format and the amount of increase or decrease as an integer. Display the new date in d/m/y format. You may call related functions as many as given increase or decrease value. Note 1: You do not need to consider leap years. Use always 28 days for month February. Note 2: Do not modify the function prototypes.   Sample Input1:          Sample Output1: 12/8/1990 -5 7/8/1990   Sample Input2:          Sample Output2: 26/2/2005 5 3/3/2005   Sample Input3:          Sample Output3: 29/12/1998 7 5/1/1999…
Question 1 is already done need help with the others though    This is the C code I have so far  #include <stdio.h>   #include <stdlib.h>   struct employees   {   char name[20];   int ssn[9];   int yearBorn, salary;   };   struct employees **emps = new employees()[10]; //Added new statement ---- bartleby     // function to read the employee data from the user   void readEmployee(struct employees *emp)   {   printf("Enter name: ");   gets(emp->name);   printf("Enter ssn: ");   for(int i =0; i <9; i++)   scanf("%d", &emp->ssn[i]);   printf("Enter birth year: ");   scanf("%d", &emp->yearBorn);   printf("Enter salary: ");   scanf("%d", &emp->salary);   }       // function to create a pointer of employee type   struct employees *createEmployee()   {   // creating the pointer   struct employees *emp = malloc(sizeof(struct employees));   // function to read the data   readEmployee(emp);   // returning the data   return emp;   }       // function to…
T/F 2. In Java, only if and if-else expressions are used in selection statements.

Chapter 2 Solutions

Starting Out with C++ from Control Structures to Objects (8th Edition)

Ch. 2.7 - Prob. 2.11CPCh. 2.7 - Which of the following is a character literal? B BCh. 2.7 - Prob. 2.13CPCh. 2.7 - Write a program that has the following character...Ch. 2.7 - What is wrong with the following program...Ch. 2.7 - Prob. 2.16CPCh. 2.7 - Write a program that stores your name, address,...Ch. 2.11 - Prob. 2.18CPCh. 2.11 - Prob. 2.19CPCh. 2.11 - Prob. 2.20CPCh. 2.14 - Is the following assignment statement valid or...Ch. 2.14 - How would you consolidate the following...Ch. 2.14 - What is wrong with the following program? How...Ch. 2.14 - Prob. 2.24CPCh. 2.16 - Prob. 2.25CPCh. 2 - How many operands does each of the following types...Ch. 2 - How may the double variables temp, weight, and age...Ch. 2 - Prob. 3RQECh. 2 - Write assignment statements that perform the...Ch. 2 - Is the following comment written using single-line...Ch. 2 - Is the following comment written using single-line...Ch. 2 - Modify the following program so it prints two...Ch. 2 - What will the following programs print on the...Ch. 2 - Multiple Choice 9. Every complete statement ends...Ch. 2 - Prob. 10RQECh. 2 - Every C++ program must have a ________. A) cout...Ch. 2 - Preprocessor directives begin with ________. A) #...Ch. 2 - The following data 72 'A' Hello World" 2.8712 are...Ch. 2 - A group of statements, such as the contents of a...Ch. 2 - Which of the following are not valid assignment...Ch. 2 - Which of the following are not valid cout...Ch. 2 - Assume w = 5, x = 4, y = 8, and z = 2. What value...Ch. 2 - How would each of the following numbers be...Ch. 2 - The negation operator is ________. A) unary B)...Ch. 2 - A(n) ___________ is like a variable, but its value...Ch. 2 - Prob. 21RQECh. 2 - T F A variable must be defined before it can be...Ch. 2 - T F Variable names may begin with a number.Ch. 2 - T F Variable names may be up to 31 characters...Ch. 2 - T F A left brace in a C++ program should always be...Ch. 2 - T F You cannot initialize a named constant that is...Ch. 2 - Prob. 27RQECh. 2 - Convert the following pseudocode to C++ code. Be...Ch. 2 - There are a number of syntax errors in the...Ch. 2 - Sum of Two Numbers Write a program that stores the...Ch. 2 - Sales Prediction The East Coast sales division of...Ch. 2 - Sales Tax Write a program that will compute the...Ch. 2 - Restaurant Bill Write a program that computes the...Ch. 2 - Average of Values To get the average of a series...Ch. 2 - Annual Pay Suppose an employee gets paid every two...Ch. 2 - Ocean Levels Assuming the oceans level is...Ch. 2 - Total Purchase A customer in a store is purchasing...Ch. 2 - Cyborg Data Type Sizes You have been given a job...Ch. 2 - Miles per Gallon A car holds 15 gallons of...Ch. 2 - Distance per Tank of Gas A car with a 20-gallon...Ch. 2 - Land Calculation One acre of land is equivalent to...Ch. 2 - Circuit Board Price An electronics company sells...Ch. 2 - Prob. 14PCCh. 2 - Triangle Pattern Write a program that displays the...Ch. 2 - Diamond Pattern Write a program that displays the...Ch. 2 - Stock Commission Kathryn bought 750 shares of...Ch. 2 - Energy Drink Consumption A soft drink company...

Additional Engineering Textbook Solutions

Find more solutions based on key concepts
Knowledge Booster
Background pattern image
Computer Science
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
SEE MORE QUESTIONS
Recommended textbooks for you
  • Text book image
    Microsoft Visual C#
    Computer Science
    ISBN:9781337102100
    Author:Joyce, Farrell.
    Publisher:Cengage Learning,
Text book image
Microsoft Visual C#
Computer Science
ISBN:9781337102100
Author:Joyce, Farrell.
Publisher:Cengage Learning,
Introduction to Variables; Author: Neso Academy;https://www.youtube.com/watch?v=fO4FwJOShdc;License: Standard YouTube License, CC-BY